Win-Test

for Project:

Welcome to the Bug Tracking System for the Win-Test contest logger. Things to note :

Feel free to report any bugs, however minor. To improve efficiency, please try to be as accurate as possible.

Please don't ask for feature requests here but on the mailing list.

Thanks for your help. Olivier F5MZN and Laurent F6FVY

Task #351 — After deleting key assigned to a LUA script, script Properties shows wrong key assignment

Attached to Project— Win-Test
Opened by Robert A. Wilson (N6TV) - Monday, 25 Aug 2014, 12:00am
Bug Report
General
Unconfirmed
No-one
All
Medium
Normal
Current WT-4.x
Undecided
0% complete

WT 4.13

  1. In the logging window, type SCRIPTS [Enter]
  2. Assign multiple LUA scripts to various keys, close dialog
  3. SCRIPTS [Enter]
  4. Select a script
  5. Click [Properties]
  6. Click [Delete] to remove key assignment
  7. Click [OK]. Note that scroll position in scripts list is unchanged (a recent fix that may have caused this new issue)
  8. Click [Properties] again (for the same script)
  9. Thekey assignment should still be none, but it displays a random key assignment here instead.

If you completely close the scripts dialog after doing one deletion, of a key assignment is deleted, it works OK, but if you try to delete multiple script key assignments before closing the Scripts Manager, it seesm to get out of synch.

Note that I am only deleting key assignments; I am not deleting any scripts.

If you cannot reproduce the problem, I may have to forward my WT.INI file and the contents of my Scripts folder.

This task depends upon

This task blocks these from closing

Comments (0) | Attachments (0) | Related Tasks (0/0) | Notifications (3) | Reminders (0) | History |